nix-config/home/features/cli/gpg.nix
GHOSCHT 7177ce3a10
Fix breakages after upgrading to NixOS 24.05
some things still have to be fixed, but normal operation can go on for
now
2024-06-29 10:10:36 +02:00

25 lines
584 B
Nix

{
lib,
pkgs,
...
}: {
programs.gpg = {
enable = true;
};
services.gpg-agent = {
enable = true;
enableSshSupport = true;
enableFishIntegration = true;
enableZshIntegration = true;
pinentryPackage = pkgs.pinentry-gnome3;
};
# Prevent clobbering SSH_AUTH_SOCK
home.sessionVariables.GSM_SKIP_SSH_AGENT_WORKAROUND = "1";
# Disable gnome-keyring ssh-agent
xdg.configFile."autostart/gnome-keyring-ssh.desktop".text = ''
${lib.fileContents "${pkgs.gnome3.gnome-keyring}/etc/xdg/autostart/gnome-keyring-ssh.desktop"}
Hidden=true
'';
}