nix-config/home/features/desktop/awesome/default.nix

37 lines
667 B
Nix

{pkgs, ...}: {
imports = [
../common
./zathura.nix
];
home = {
file.".wallpapers" = {
source = ../../../../rsc/wallpaper;
recursive = true;
};
file.".config/awesome/" = {
source = ../../../../rsc/config/awesome;
recursive = true;
};
file.".config/picom/" = {
source = ../../../../rsc/config/picom;
recursive = true;
};
file.".config/rofi" = {
source = ../../../../rsc/config/rofi;
recursive = true;
};
packages = with pkgs; [
picom
rofi
redshift
xbindkeys
clipmenu
flameshot
xclip
brightnessctl
feh
];
};
}