84 lines
2.4 KiB
Nix
84 lines
2.4 KiB
Nix
# This is your home-manager configuration file
|
|
# Use this to configure your home environment (it replaces ~/.config/nixpkgs/home.nix)
|
|
{
|
|
inputs,
|
|
outputs,
|
|
lib,
|
|
config,
|
|
pkgs,
|
|
vars,
|
|
...
|
|
}: {
|
|
# You can import other home-manager modules here
|
|
imports =
|
|
[
|
|
# If you want to use modules your own flake exports (from modules/home-manager):
|
|
# outputs.homeManagerModules.example
|
|
|
|
# Or modules exported from other flakes (such as nix-colors):
|
|
# inputs.nix-colors.homeManagerModules
|
|
|
|
# You can also split up your configuration and import pieces of it here:
|
|
../features/cli
|
|
../features/general/xdg-dirs.nix
|
|
]
|
|
++ (builtins.attrValues outputs.homeManagerModules);
|
|
|
|
nixpkgs = {
|
|
# You can add overlays here
|
|
overlays =
|
|
[
|
|
# Add overlays your own flake exports (from overlays and pkgs dir):
|
|
# outputs.overlays.additions
|
|
# outputs.overlays.modifications
|
|
# outputs.overlays.unstable-packages
|
|
|
|
# You can also add overlays exported from other flakes:
|
|
# neovim-nightly-overlay.overlays.default
|
|
|
|
# Or define it inline, for example:
|
|
# (final: prev: {
|
|
# hi = final.hello.overrideAttrs (oldAttrs: {
|
|
# patches = [ ./change-hello-to-hi.patch ];
|
|
# });
|
|
# })
|
|
]
|
|
++ (builtins.attrValues outputs.overlays);
|
|
# Configure your nixpkgs instance
|
|
config = {
|
|
# Disable if you don't want unfree packages
|
|
allowUnfree = true;
|
|
permittedInsecurePackages = [
|
|
"electron-24.8.6" #fixes Feishin & Webcord
|
|
];
|
|
# Workaround for https://github.com/nix-community/home-manager/issues/2942
|
|
allowUnfreePredicate = _: true;
|
|
};
|
|
};
|
|
|
|
nix = {
|
|
package = lib.mkDefault pkgs.nix;
|
|
settings = {
|
|
experimental-features = ["nix-command" "flakes" "repl-flake"];
|
|
warn-dirty = false;
|
|
};
|
|
};
|
|
|
|
home = {
|
|
username = lib.mkDefault vars.user;
|
|
homeDirectory = lib.mkDefault "/home/${config.home.username}";
|
|
# https://nixos.wiki/wiki/FAQ/When_do_I_update_stateVersion
|
|
stateVersion = "23.11";
|
|
};
|
|
|
|
# Add stuff for your user as you see fit:
|
|
# programs.neovim.enable = true;
|
|
# home.packages = with pkgs; [ steam ];
|
|
|
|
# Enable home-manager and git
|
|
programs.home-manager.enable = true;
|
|
programs.git.enable = true;
|
|
|
|
# Nicely reload system units when changing configs
|
|
systemd.user.startServices = "sd-switch";
|
|
}
|