106 lines
3 KiB
Nix
106 lines
3 KiB
Nix
# This is your system's configuration file.
|
|
# Use this to configure your system environment (it replaces /etc/nixos/configuration.nix)
|
|
{
|
|
inputs,
|
|
outputs,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
# You can import other NixOS modules here
|
|
imports = [
|
|
# If you want to use modules your own flake exports (from modules/nixos):
|
|
# outputs.nixosModules.example
|
|
|
|
# Or modules from other flakes (such as nixos-hardware):
|
|
inputs.hardware.nixosModules.common-cpu-amd-pstate
|
|
inputs.hardware.nixosModules.common-gpu-nvidia-nonprime
|
|
inputs.hardware.nixosModules.common-pc-ssd
|
|
|
|
# You can also split up your configuration and import pieces of it here:
|
|
# ./users.nix
|
|
|
|
# Import your generated (nixos-generate-config) hardware configuration
|
|
./hardware-configuration.nix
|
|
|
|
../common/global
|
|
../common/optional/desktop/awesome.nix
|
|
|
|
../common/optional/systemd-boot.nix
|
|
../common/optional/wireshark.nix
|
|
../common/optional/kde-connect.nix
|
|
../common/optional/gnome-keyring.nix
|
|
../common/optional/adb.nix
|
|
../common/optional/docker.nix
|
|
../common/optional/gaming/gamemode.nix
|
|
../common/optional/gaming/steam.nix
|
|
../common/optional/desktop/japanese.nix
|
|
../common/optional/udisks.nix
|
|
];
|
|
|
|
nixpkgs = {
|
|
# You can add overlays here
|
|
overlays = [
|
|
# Add overlays your own flake exports (from overlays and pkgs dir):
|
|
outputs.overlays.additions
|
|
outputs.overlays.modifications
|
|
outputs.overlays.unstable-packages
|
|
|
|
# You can also add overlays exported from other flakes:
|
|
# neovim-nightly-overlay.overlays.default
|
|
|
|
# Or define it inline, for example:
|
|
# (final: prev: {
|
|
# hi = final.hello.overrideAttrs (oldAttrs: {
|
|
# patches = [ ./change-hello-to-hi.patch ];
|
|
# });
|
|
# })
|
|
];
|
|
# Configure your nixpkgs instance
|
|
config = {
|
|
# Disable if you don't want unfree packages
|
|
allowUnfree = true;
|
|
firefox.enablePlasmaBrowserIntegration = true;
|
|
segger-jlink.acceptLicense = true;
|
|
permittedInsecurePackages = ["segger-jlink-qt4-794l"];
|
|
};
|
|
};
|
|
|
|
networking.hostName = "adalbert";
|
|
|
|
services.udev.packages = [inputs.heliox-cli.packages.x86_64-linux.default pkgs.segger-jlink];
|
|
environment.systemPackages = [inputs.heliox-cli.packages.x86_64-linux.default];
|
|
|
|
# Personalausweis reader
|
|
programs.ausweisapp.enable = true;
|
|
programs.ausweisapp.openFirewall = true; # also sets firewall entry
|
|
|
|
programs.nix-ld.enable = true;
|
|
|
|
# services.xserver.displayManager.sddm.enable = true;
|
|
services.xserver.displayManager.gdm.enable = true;
|
|
|
|
# Force disable Nvidia PRIME, needed by nix-hardware
|
|
# hardware.nvidia.prime.offload.enable = false;
|
|
|
|
programs.coolercontrol = {
|
|
enable = true;
|
|
nvidiaSupport = true;
|
|
};
|
|
boot.binfmt.emulatedSystems = [
|
|
"aarch64-linux"
|
|
"riscv64-linux"
|
|
];
|
|
|
|
programs = {
|
|
adb.enable = true;
|
|
dconf.enable = true;
|
|
};
|
|
|
|
hardware = {
|
|
opengl.enable = true;
|
|
opentabletdriver.enable = true;
|
|
};
|
|
|
|
# https://nixos.wiki/wiki/FAQ/When_do_I_update_stateVersion
|
|
system.stateVersion = "23.11";
|
|
}
|