28 lines
486 B
Nix
28 lines
486 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
services = {
|
|
# Enable the X11 windowing system.
|
|
xserver = {
|
|
enable = true;
|
|
# Enable touchpad support
|
|
libinput.enable = true;
|
|
# Remove xterm terminal
|
|
excludePackages = with pkgs; [xterm];
|
|
modules = [pkgs.xf86_input_wacom];
|
|
wacom.enable = true;
|
|
};
|
|
};
|
|
|
|
# Install installation
|
|
environment = {
|
|
systemPackages = with pkgs; [
|
|
# X11
|
|
xorg.xkbutils
|
|
xorg.xkill
|
|
];
|
|
};
|
|
}
|