22 lines
583 B
Nix
22 lines
583 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
programs.kdeconnect.enable = true;
|
|
|
|
# Create system services for KDE connect
|
|
systemd.user.services.kdeconnect = {
|
|
description = "Adds communication between your desktop and your smartphone";
|
|
after = ["graphical-session-pre.target"];
|
|
partOf = ["graphical-session.target"];
|
|
wantedBy = ["graphical-session.target"];
|
|
|
|
serviceConfig = {
|
|
#Environment = "PATH=${config.home.profileDirectory}/bin";
|
|
ExecStart = "${pkgs.plasma5Packages.kdeconnect-kde}/libexec/kdeconnectd";
|
|
Restart = "on-abort";
|
|
};
|
|
};
|
|
}
|