nix-config/pkgs/protonup-rs/default.nix

35 lines
907 B
Nix

{
lib,
fetchFromGitHub,
rustPlatform,
}:
rustPlatform.buildRustPackage rec {
pname = "protonup-rs";
version = "v0.6.0";
src = fetchFromGitHub {
owner = "auyer";
repo = pname;
rev = version;
hash = "sha256-IE8QO9LaEllTYRRDA704SNWp4Ap2NQmoYMaKX4l9McY=";
};
cargoBuildFlags = "-p protonup-rs";
# tests somehow fail, but compiled result works
checkFlags = [
"--skip=github::tests::test_fetch_data_from_tag"
"--skip=github::tests::test_get_release"
"--skip=github::tests::test_list_releases"
];
cargoSha256 = "sha256-/8JhMDwBP3INP9+YlkTc+SwGnZypcj7OJingiyw1pcU=";
meta = with lib; {
description = "A Rust app to Install and Update GE-Proton for Steam, and Wine-GE for Lutris";
homepage = "https://github.com/auyer/Protonup-rs";
license = licenses.asl20;
maintainers = with maintainers; [GHOSCHT];
mainProgram = "protonup-rs";
};
}