base-station/Firmware/flake.nix
GHOSCHT d86edf5e9a
Add nix flake
Provides system-locket platformio
2023-12-22 17:09:34 +01:00

28 lines
506 B
Nix

{
inputs = {
nixpkgs = {
url = "github:nixos/nixpkgs-channels/nixos-unstable";
};
flake-utils = {
url = "github:numtide/flake-utils";
};
};
outputs = {
nixpkgs,
flake-utils,
...
}:
flake-utils.lib.eachDefaultSystem (
system: let
pkgs = import nixpkgs {
inherit system;
};
in rec {
devShell = pkgs.mkShell {
buildInputs = with pkgs; [
platformio
];
};
}
);
}